Build failures due to new sudo-enabled Precise and Trusty images
Incident Report for Travis CI
Resolved
We published new default sudo-enabled Precise and Trusty images yesterday, as detailed here: https://docs.travis-ci.com/user/build-environment-updates/2016-08-24/. We will publish further updates via Twitter and https://docs.travis-ci.com/user/build-environment-updates/.

If you run into any problems that aren't already captured as issues in either the central Travis issue tracker (https://github.com/travis-ci/travis-ci/issues?q=is%3Aopen+is%3Aissue+label%3Agce-image-update-2016-08) or the packer-templates repo (https://github.com/travis-ci/packer-templates/issues), please email support@travis-ci.com and we'll help out.
Posted Aug 25, 2016 - 15:07 UTC
Update
We've published new default sudo-enabled Precise and Trusty images with the following fixes:

- Fixed the lack of `/opt` being writeable: https://github.com/travis-ci/packer-templates/issues/217
- Added some additional Go versions to be pre-installed in our Precise Go image: https://github.com/travis-ci/packer-templates/pull/238
- Versions added are: `1.4.3`, `1.5.4`, `1.6.3`
- Versions removed are: `1.4.1`
- Fixed issues caused by the presence of `127.0.1.1 localhost ...` being in `/etc/hosts`, it now only has `ip4-loopback`.
- Trusty: https://github.com/travis-ci/travis-cookbooks/pull/742
- Precise: https://github.com/travis-ci/travis-cookbooks/pull/743

We will continue to make and publish fixes throughout week. If you run into any problems that do not have any open issue, please email support@travis-ci.com and we'll help out
Posted Aug 15, 2016 - 21:25 UTC
Update
We've published new default sudo-enabled Precise and Trusty images with the following fixes:
- Fixed the lack of `perlbrew` and `cpanm` in the stable Trusty images: https://github.com/travis-ci/travis-ci/issues/6439
- Fixed the lack of a default Go installation on all Trusty images, Go 1.6.3 is now available in all of them: https://github.com/travis-ci/travis-ci/issues/6445

We will continue to make and publish fixes next week. If you run into any problems that do not have any open issue, please email support@travis-ci.com and we'll help out
Posted Aug 12, 2016 - 22:18 UTC
Update
We've published new default sudo-enabled Precise and Trusty images with the following fixes:
- Disable IPv6 (this was recently enabled in the upstream Ubuntu images we build on, but it causes issues in our build environments)
- Ensuring IPv6 networking is disabled on all interfaces
- Ensuring that there aren't any IPv6 entries in /etc/hosts
- Including the `docker-compose` binary again (it being missing was a mistake on our part)
- Ensuring mongodb is disabled on boot up

We are continuing to work with customers on work-arounds and work on fixes to the build images. Determining the root cause of the IPv6 issue and how to remove it occupied a large amount of our engineering time yesterday, so we hope to be able to begin shipping other fixes more frequently over the coming days.
If you're seeing issues and need assistance, please email support@travis-ci.com
Posted Aug 11, 2016 - 18:00 UTC
Monitoring
Due to the outage earlier today, https://www.traviscistatus.com/incidents/2p40l49r3yxd, many users are seeing builds fail due to differences in the new default sudo-enabled Precise and Trusty images. We're working with users to find fixes or work-arounds as quickly as possible. If you see issues with your builds, please email support@travis-ci.com. Thanks for your patience and understanding.
Posted Aug 09, 2016 - 23:48 UTC