Build VMs not booting on the sudo-enabled infrastructure
Incident Report for Travis CI
Resolved
After patch was rolled out, sudo enabled builds are processing normally again. We have been monitoring for errors for the last hour or so, and we are marking this incident as resolved. Please contact support if you are experiencing problems with your sudo enabled builds.
Posted 3 months ago. Sep 10, 2018 - 20:51 UTC
Update
We are in the last rounds of rollouts for the new patch, and waiting on the last of the VM clean ups before restarting the remainder of services. Sudo enabled builds are running at a reduced capacity. Thank you for your patience.
Posted 3 months ago. Sep 10, 2018 - 18:55 UTC
Update
We have identified an error condition that is causing our job execution service to crash. We are in the process of rolling out a patch for this service, and cleaning up non-terminated job VMs that were leaked by the crash.
Posted 3 months ago. Sep 10, 2018 - 17:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Sep 10, 2018 - 16:44 UTC
Update
We are seeing this behavior for open source builds as well.
Posted 3 months ago. Sep 10, 2018 - 16:40 UTC
Investigating
We are receiving reports of VMs not booting for private builds on the sudo-enabled infrastructure (i.e. `sudo: required`). Our team is looking into it and we'll post updates as soon as we know more. Thank you for your patience!
Posted 3 months ago. Sep 10, 2018 - 16:28 UTC
This incident affected: Builds Processing (Linux Builds (Trusty and Precise on GCE)).