Emergency maintenance for .com logs database
Incident Report for Travis CI
Resolved
Maintenance work and verification have been completed.
Posted Feb 17, 2017 - 17:46 UTC
Monitoring
At this time we've completed verification and the maintenance work is completed. We'll continue to monitor things closely for another 60 minutes, then resolve the issue if nothing is wrong.
Posted Feb 17, 2017 - 15:22 UTC
Update
We are continuing to do verification at this time. New logs should be visible in the web UI and cli. Recently finished job logs may be delayed.
Posted Feb 17, 2017 - 15:15 UTC
Update
The database changes are completed. We are beginning the process of testing things and verifications to see if we're ready to exit maintenance mode. We'll provide another update in 15 minutes.
Posted Feb 17, 2017 - 15:03 UTC
Update
This incident originally mentions the .org logs database, but this maintenance is for the .com logs databases. Apologies for any confusion.
Posted Feb 17, 2017 - 14:47 UTC
Identified
We've identified that we need to take emergency maintenance for the .com logs database in order to increase the available resources of this database and ensure overall stability of the logs system.

Expected User Impact:

Delays in:

- Seeing log updates in the web interface
- Delays in viewing logs for recently finished jobs.

Our initial expectation is for approximately. 60 minutes in this state. We'll provide an update at least 15 minutes after we begin the needed changes.
Posted Feb 17, 2017 - 14:38 UTC