Builds with `sudo: required` intermittently failing on travis-ci.com and travis-ci.org
Incident Report for Travis CI
Resolved
We're seeing normal rates of processing and job state finishes for our sudo required builds and marking this as resolved. If you see problems with your sudo builds, please contact support@travis-ci.com.
Posted 4 months ago. Aug 10, 2018 - 20:34 UTC
Monitoring
We have identified the reason the network packets were getting dropped and would cause intermittent network issues. We've proceeded with fixing the situation. We are monitoring to see if things stay stable. Thanks for hanging in there with us.
Posted 4 months ago. Aug 10, 2018 - 18:21 UTC
Identified
These issues seem to be stemming from network packets getting dropped in some parts of our sudo-enabled infrastructure. We are communicating with our infrastructure provider to get more insights.
Posted 4 months ago. Aug 10, 2018 - 17:10 UTC
Investigating
We are currently receiving reports of private builds with `sudo: required` intermittently failing on travis-ci.com. The behaviors reported are that the builds are stalling while downloading something (e.g. the cache, a Docker image or Chrome) or because of SSL/TLS errors. Other behaviors are also possible. We are looking into it and we will post an update ASAP. Thank you for your patience!
Posted 4 months ago. Aug 10, 2018 - 15:19 UTC
This incident affected: Builds Processing (Linux Builds (Trusty and Precise on GCE)).