apt-get install failures on sudo enabled Precise and Trusty builds
Incident Report for Travis CI
Resolved
We've confirmed our update is working as expected and previously errored builds will be able to `sudo apt-get install ...` if rerun. If you still see issues, please email support@travis-ci.com
Posted Aug 20, 2016 - 01:37 UTC
Monitoring
We've deployed an update which has restored things so that `sudo apt-get update` is run at the beginning of builds, which will result in successful `sudo apt-get install ...` commands. We're following with up with all users who reported issues.
Posted Aug 20, 2016 - 01:17 UTC
Identified
Yesterday we made a change to no longer try to install a libc update in our sudo enabled images at runtime, as it's now pre-installed, but we've determined that removing it has removed a `sudo apt-get update` that was running at the beginning of every build and the removal of this is causing issues for many users. We are rolling back this change now.
Posted Aug 20, 2016 - 01:01 UTC