Maven connectivity issues
Incident Report for Travis CI
Resolved
We have deployed the change to use Google's maven central mirror to improve the availability of Maven repositories.
Posted 25 days ago. Jun 27, 2019 - 21:11 UTC
Monitoring
The Sonatype team has safe listed all of our IP addresses and connections to Maven Central should now work. We will continue to monitor and please do not hesitate to contact us at support@travis-ci.com if you’re still observing Maven connectivity issues.
Posted 25 days ago. Jun 27, 2019 - 19:56 UTC
Update
The Sonatype team has been investigating to safelist all of our IP addresses and confirm if this fixes the issues connecting to Maven Central: https://issues.sonatype.org/browse/MVNCENTRAL-4985.
We'll continue to post updates as we have more information to share.
For centralized reports of this situation please use the community forum at: https://travis-ci.community/t/continuous-maven-repo-403/3908/5
Posted 25 days ago. Jun 27, 2019 - 10:37 UTC
Investigating
We're currently investigating an issue with Maven builds accessing Maven central, with error "403" and "Access Denied" We believe this could be related to the extending of IP ranges earlier this week and the need for them to be whitelisted by Maven. We've reached out to Sonatype, and we are working to resolve this issue as soon as possible.
Posted 26 days ago. Jun 26, 2019 - 16:07 UTC
This incident affected: Builds Processing (Linux and Windows Builds).