Upstream connectivity issues impacting builds

Incident Report for Travis CI

Resolved

Our service has recovered and is operating normally. Thanks to everyone upstream who dealt with this outage, and thank you for your patience. 💜
Posted Oct 22, 2016 - 09:20 UTC

Update

We are re-enabling GitHub syncs now.
Posted Oct 22, 2016 - 08:45 UTC

Update

Builds are starting to process again as GitHub recovers. In order to improve our stability, we have disabled github syncs for the time being. We will re-enable them once upstream is stable.
Posted Oct 21, 2016 - 20:05 UTC

Update

DNS is still unavailable or unreliable for several of our upstream services, including Heroku and GitHub. We are continuing to monitor the situation.
Posted Oct 21, 2016 - 18:27 UTC

Update

We're still seeing issues with clones from GitHub causing most builds to fail.
Posted Oct 21, 2016 - 17:45 UTC

Update

We're continuing to see some instability with upstream dependencies, https://twitter.com/githubstatus/status/789502047242559488, so we are monitoring closely and will adjust our capacity as needed
Posted Oct 21, 2016 - 16:26 UTC

Update

We're seeing a large backlog for public container-based builds, we're scaling up our capacity for these jobs to help us get the backlog processed quicker. Thanks for your patience as we work to recover from the upstream issues.
Posted Oct 21, 2016 - 16:06 UTC

Update

We are working through back logs. We appreciate your patience.
Posted Oct 21, 2016 - 15:05 UTC

Monitoring

Upstream DNS issues have been resolved. We are processing builds, and working through back logs on Mac and container builds.
Posted Oct 21, 2016 - 13:44 UTC

Identified

We have confirmed that connectivity issues upstream are causing delays or failures building and processing jobs. We are monitoring for a resolution.
Posted Oct 21, 2016 - 12:29 UTC

Investigating

Several upstream providers are experiencing connectivity issues. Builds may fail prematurely or fail to process.
Posted Oct 21, 2016 - 12:19 UTC