Build delays for private repositories
Incident Report for Travis CI
Resolved
The backlog for sudo: required GCE and macOS private builds has cleared.
Posted Jun 14, 2017 - 22:09 UTC
Update
Due to resource contention on one of our backend services, the backlog for private mac and sudo enabled builds is taking longer-than-normal to process. Builds are processing at full capacity, and the backlog continues to decrease.
Posted Jun 14, 2017 - 21:43 UTC
Update
Private travis-ci.com builds for mac and sudo-enabled trusty/precise are running at full capacity, thank you for your patience as we work through the remaining backlog
Posted Jun 14, 2017 - 20:03 UTC
Update
The backlog on our container-based Precise infrastructure (i.e. sudo: false + dist: precise) is now cleared.
Posted Jun 14, 2017 - 19:21 UTC
Update
The backlog on our container-based Trusty infrastructure (i.e. sudo: false + dist: trusty) is now cleared.
Posted Jun 14, 2017 - 19:17 UTC
Monitoring
We are seeing a downward trend in the backlogs of all our infrastructures. We will update when they have cleared. Thank you.
Posted Jun 14, 2017 - 19:15 UTC
Identified
We have proceeded to restart a component that was failing to process job requests. Upon the reboot, the jobs now seem to be processing normally. We are monitoring the situation closely.
Posted Jun 14, 2017 - 18:48 UTC
Investigating
We are currently seeing delays for builds on private repositories. We are currently escalating the issue with one of our 3rd party provider and will post an update as soon as we know more. Thank you for your patience!
Posted Jun 14, 2017 - 18:25 UTC