Build delays on macOS job execution infrastructure
Incident Report for Travis CI
Resolved
The incident is resolved. Thank you for your patience.
Posted May 12, 2018 - 00:56 UTC
Monitoring
We are processing the backlog normally.
Posted May 11, 2018 - 22:29 UTC
Update
We've identified the cause to be clean up service not functioning, causing one of the datastores to run out of space. No swap files for macOS vms can be created and no macOS vms can be powered on for some of our xcode8.3 and xcode9.2 images. We will be moving our mastered xcode images to other datastores before troubleshooting the clean up service. In the meantime you can switch to osx_image: xcode9.3 in your .travis.ymls to get builds going.
Posted May 11, 2018 - 20:14 UTC
Update
We are currently waiting to hear back from our infrastructure provider regarding our next steps to resolve this incident.
Posted May 11, 2018 - 19:16 UTC
Identified
We are currently experiencing build delays on the macOS job execution infrastructure.
Posted May 11, 2018 - 17:37 UTC
This incident affected: Builds Processing (Mac Builds).