Network slowness/timeouts for sudo-enabled builds
Incident Report for Travis CI
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 20, 2018 - 18:40 UTC
Monitoring
Our upgrade is complete and things are stabilizing. The NATs are no longer saturated. We continue to monitor traffic levels.
Posted 3 months ago. Sep 20, 2018 - 17:01 UTC
Update
We are in the process of increasing the size of our NAT instances. We expect some minor network disruptions as routes are updated.
Posted 3 months ago. Sep 20, 2018 - 16:30 UTC
Identified
The issue has been identified and it's caused by the saturation of the NAT of the our sudo-enabled infrastructure. We are currently working on fixing that.
Posted 3 months ago. Sep 20, 2018 - 15:28 UTC
Investigating
We are receiving reports of builds with `sudo: required` experiencing slowness while executing commands accessing the network e.g. `docker pull`. We are currently looking into it and we'll keep you updated. Thank you for your patience!
Posted 3 months ago. Sep 20, 2018 - 15:15 UTC
This incident affected: Builds Processing (Linux Builds (Trusty and Precise on GCE)).