Unreliable or intermittent network connectivity for Linux and Windows builds
Incident Report for Travis CI
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 07, 2019 - 14:40 UTC
Monitoring
The NAT gateway changes have been fully reverted. Network performance and reliability in your builds should be back to normal. We’ll be monitoring for a short while before closing this incident.
Posted 2 months ago. Aug 07, 2019 - 12:38 UTC
Update
At this point, we've reverted half of the NAT gateway updates and a 50% of the Linux and Windows jobs currently processed have better network performance already. We'll provide another update as soon as this process is complete. Thanks for your patience.
Posted 2 months ago. Aug 07, 2019 - 10:37 UTC
Identified
We've identified an issue with the latest changes to update the NAT gateways. While this change was meant to improve maintainability, we are rolling it back due to the degraded network performance. We're expecting this provides network speed improvements within the next hour. We will provide additional updates at the top of the hour. Thank you
Posted 2 months ago. Aug 07, 2019 - 07:54 UTC
Update
We are continuing to investigate this issue.
Posted 2 months ago. Aug 06, 2019 - 17:55 UTC
Investigating
We are receiving reports of Linux and Windows builds where network connectivity is unreliable, intermittently working or slow. We are opening this incident to acknowledge the issue and also keep you posted on our work to solve it. Thank you for your patience.
Posted 2 months ago. Aug 06, 2019 - 17:55 UTC
This incident affected: Builds Processing (Linux and Windows Builds).