API and Build Image slowness for public builds

Incident Report for Travis CI

Resolved

The API has remained stable for a sufficient amount of time so we're marking this incident as resolved. Thanks for your patience.
Posted Oct 09, 2015 - 00:21 UTC

Monitoring

At this time things have stabilized and API response times have returned to expected levels. We're continuing to monitor things closely for a while longer.
Posted Oct 08, 2015 - 23:42 UTC

Identified

Unfortunately, we're continuing to see instability with the cluster that we use for memcache. Our provider is aware of the issue and is working to resolve it. While this issue is happening API responses are slower than normal and build images may be out of date or not return results.
Posted Oct 08, 2015 - 22:50 UTC

Monitoring

At this time the memcache cluster has stabilized and we're seeing response times for the API return to normal. We're continuing to monitoring until we see them fully settle down. If you have any issues, please email support@travis-ci.com
Posted Oct 08, 2015 - 22:01 UTC

Identified

We're currently seeing API and potential build image slowness due to an ongoing issue with the memcache cluster which the API uses as part of build image caching. We are working to resolve this as soon as possible.
Posted Oct 08, 2015 - 21:50 UTC