2015-04-28 Build Environment Update rollback and cancellation
Scheduled Maintenance Report for Travis CI
Completed
.org rollback is complete. We are working through back logs while adding more capacity.
Posted over 4 years ago. Apr 28, 2015 - 21:39 UTC
Update
We are still performing rollback on the .org side. Additional capacity is a bit scarce at the moment. We will keep you updated as we monitor the progress.
Posted over 4 years ago. Apr 28, 2015 - 20:35 UTC
Update
The rollback is complete for .com containers.
Posted over 4 years ago. Apr 28, 2015 - 17:29 UTC
Update
We continue to roll back the updates on the container builds. We have a few more to go on .com; .org is a little behind, due to the capacity issue detailed in http://stspg.io/10ao
Posted over 4 years ago. Apr 28, 2015 - 17:15 UTC
Update
The rollback is in progress in the container infrastructure. The process is gradual, and it will take a few hours before all jobs will get the rollback. Please check the "Build system information" fold to check which image your job is using.
Posted over 4 years ago. Apr 28, 2015 - 14:25 UTC
Update
Rollback is complete in the standard infrastructure. Starting rollback with the container infrastructure now.
Posted over 4 years ago. Apr 28, 2015 - 13:14 UTC
In progress
We are starting the rollback on the standard infrastructure now.
Posted over 4 years ago. Apr 28, 2015 - 13:10 UTC
Update
We will be rolling back the 2015-04 updates in a few minutes.
Posted over 4 years ago. Apr 28, 2015 - 12:57 UTC
Scheduled
We will roll back the update we rolled out on 2015-04-27 due to reports of errors.

(Originally scheduled for 2015-04-09 15:00 UTC, rescheduled to 2015-04-27 15:00 UTC.)

We have received numerous reports of various problems with the most recent updates.
They are collected here: https://github.com/travis-ci/travis-ci/labels/2015-04%20build%20update%20issue.

Rather than pushing through for another update, we have decided to cancel the April update and concentrate on the quality June upgrade and a better long-term build environment update planning.

We know that some of our users want MySQL 5.6 desperately, so select images (Ruby, PHP, Python, Node.js) for this 2015-04-27 updates will be available for those who wish to use it upon request. Please email us at support@travis-ci.com with the name of the repository you wish to use. (For this, you will have to use the standard infrastructure.)
Posted over 4 years ago. Apr 28, 2015 - 04:05 UTC