Slow booting Linux builds for both open source and private repositories
Incident Report for Travis CI
Resolved
Backlog on travis-ci.org has cleared has of 2019-07-03 2:14 UTC. Thanks again for your continued patience during this incident.
Posted 2 months ago. Jul 03, 2019 - 02:45 UTC
Monitoring
Backlog on travis-ci.com has cleared around 21:55 UTC. We are monitoring travis-ci.org's backlog closely.
Posted 3 months ago. Jul 02, 2019 - 22:21 UTC
Update
Sorry for the lack of updates. It's been challenging to remain below the API rate-limit and the backlogs haven't been decreasing at a steady pace as previously mentioned. We now confirm that the backlog on .com is decreasing at a comfortable pace while the backlog on .org is over its peak. Thanks for hanging in there with us.
Posted 3 months ago. Jul 02, 2019 - 21:07 UTC
Identified
We’ve made progress in being able to stay under the API rate-limit and things are looking better on travis-ci.com. A higher backlog of jobs remains on travis-ci.org. We’ll keep you posted on the status of each backlog on a timely basis.
Posted 3 months ago. Jul 02, 2019 - 17:22 UTC
Update
We are currently hitting the API rate-limit when using our Cloud Provider’s API that is preventing us from creating/deleting VMs. We are looking into getting the system back under the API rate-limit threshold. Thank you for your patience.
Posted 3 months ago. Jul 02, 2019 - 16:25 UTC
Investigating
We are receiving reports of slow booting Linux builds. We are currently looking into it.
Posted 3 months ago. Jul 02, 2019 - 15:16 UTC
This incident affected: Builds Processing (Linux and Windows Builds).