Network issues for both sudo-disabled and sudo-enabled builds
Incident Report for Travis CI
Resolved
The networking issues look resolved on our side. We are sorry for the inconveniences this has caused to you and your teams. Please reach out to support@travis-ci.com if you are still having problems with your builds. Thank you for your understanding.
Posted May 10, 2018 - 15:39 UTC
Update
We have changed the build script to not default to running apt-get update for the time being, unless we're able to auto-detect that your build uses apt-get install. If your build requires it in other ways, please do opt in via .travis.yml. The build log gives instructions on how to opt in.
Posted May 09, 2018 - 15:23 UTC
Update
We are now also seeing builds timing out on the sudo-enabled infrastructure (i.e. builds with `sudo: required`). We are continuing to look into it. Thank you for your patience.
Posted May 09, 2018 - 13:52 UTC
Update
We have switched to a different mirror of the upstream ubuntu package repository, build startup time is recovering. We continue to monitor closely.
Posted May 09, 2018 - 12:11 UTC
Monitoring
We have identified an issue with running apt-get update on sudo disabled Linux builds running on EC2. A subset of builds have been hanging on this step or often even timed out. It looks like the issue has resolved. We are continuing to monitor this.
Posted May 09, 2018 - 08:25 UTC
Investigating
We are seeing network issues on sudo disabled builds running on EC2, causing builds to hang and time out. We are looking into this.
Posted May 09, 2018 - 07:17 UTC
This incident affected: Builds Processing (Linux and Windows Builds).