This is reported to have been fixed as of 17:00 UTC.
Posted Jul 06, 2016 - 17:36 UTC
Update
We're getting some reports of the 502s still appearing after the workaround was deployed, we're looking into it.
Posted Jul 06, 2016 - 10:30 UTC
Update
We're continuing to investigate the issue. In the meantime we've deployed a temporary fix which we believe should resolve most errors for the time being. Please let us know if you're seeing npm errors other than "fetch failed with status code 502".
Posted Jul 06, 2016 - 10:17 UTC
Investigating
We're investigating reports of npm installs failing with 502 errors in builds.