Build job errors when acquiring repository from GitHub (GitHub SSH key update)
Incident Report for Travis CI
Resolved
The issue seems resolved. If you encounter further roadbloacks in repositories using Custom SSH Key in Travis CI, specifically on git repository cloning stage, please validate if a matching key pair is still available at GitHub. If not, removing old Custom SSH Key in Travis CI repository settings and regenerating the Custom SSH Key in Travis CI may help unblock your build jobs.
Posted Mar 24, 2023 - 17:05 UTC
Monitoring
We have deployed hotfix replacing main Github host RSA SSH keys and are monitoring the builds. Users with Custom SSH Key in Travis CI repository settings should be able to build correctly now.
Posted Mar 24, 2023 - 12:47 UTC
Identified
Users utilizing Custom SSH Key in Travis CI private repository settings may experience build errors or warnings on git checkout. This is due main SSH keys being updated by GitHub (see https://github.blog/2023-03-23-we-updated-our-rsa-ssh-host-key/ ). We are working on updating our build environments configuration to utilize updated GitHub SSH keys. Users not utilizing Custom SSH keys are not affected.
Posted Mar 24, 2023 - 10:12 UTC
This incident affected: Builds Processing (Mac Builds, Linux and Windows Builds) and Third Party Services (GitHub).