Missing build requests for Pull Request events
Incident Report for Travis CI
Resolved
The issue has been resolved.
Posted almost 2 years ago. Mar 10, 2017 - 18:43 UTC
Update
We have a report of close/reopen not triggering a PR build. In this case, try pushing a new commit (or force on top).
Posted almost 2 years ago. Mar 10, 2017 - 18:27 UTC
Monitoring
We have deployed the fix for the upstream API change. As previous PR build requests are lost, please close and reopen the affected PRs to trigger builds.
Posted almost 2 years ago. Mar 10, 2017 - 18:03 UTC
Identified
We have traced the missing builds issue to a change in the upstream GitHub API that introduced new PR statuses we have not previously accounted for in our GitHub API client. This caused PR requests to be dropped. We are working on a fix to account for the new statuses.
Posted almost 2 years ago. Mar 10, 2017 - 17:52 UTC
Investigating
We're currently investigating reports of missing builds for Pull Requests in https://travis-ci.com and https://travis-ci.org
Posted almost 2 years ago. Mar 10, 2017 - 16:21 UTC