Stopping all workers for OS X builds for both public and privates repositories
Incident Report for Travis CI
Resolved
We have finally caught up with the backlog for open source OS X builds. We are sorry for the inconveniences you went through and we cannot thank you enough for your enduring patience. Wishing you all a great weekend!
Posted Oct 15, 2016 - 19:36 UTC
Update
We apologize for the extended delays. We've completed needed work to help stabilize things and try to improve our overall throughput. We are beginning to resume builds.
Posted Oct 14, 2016 - 04:45 UTC
Update
The maintenance is taking longer than expected but we hope to resume builds shortly
Posted Oct 14, 2016 - 03:29 UTC
Update
We'll be pausing builds temporarily to run some quick maintenance which should help us get through the backlog a bit quicker
Posted Oct 14, 2016 - 02:54 UTC
Update
We are currently estimating that we will have processed the backlog for OS X builds on open source repositories in approximately 8 hours. Take note, however, that it might be faster than that since there are fewer builds at this time. We will continue to keep you informed about the situation and update the ETA accordingly.
Posted Oct 14, 2016 - 01:05 UTC
Update
We have caught up with the backlog for OS X builds on private repositories. We are continuing to process the backlog of OS X builds for open source repositories. Although this backlog is again higher than we last reported, it seems to have peaked and we are now seeing a downward trend. Hopefully, we will have an ETA with our next update. Thank you.
Posted Oct 14, 2016 - 00:17 UTC
Update
We are still processing OS X builds at full capacity. We estimate the backlog for private builds will be consumed in 2 hours. Unfortunately, the backlog for open source builds is a bit higher than when we last provided an update hence it will take longer to process entirely. Thanks for hanging in there.
Posted Oct 13, 2016 - 20:57 UTC
Update
We are currently processing OS X builds at full capacity. We estimate that the backlog of build jobs for private repositories should be consumed in about 3 hours (though this might change with the traffic of the PST timezone). The backlog for build jobs for open source repositories will take longer as it's currently increasing. We will continue to monitor things and give you an update again soon. Thank you for your understanding.
Posted Oct 13, 2016 - 17:45 UTC
Monitoring
We've been able clean up all the stale OS X VMs. Workers have been restarted and we are now processing OS X builds again. We'll update again with the state of the backlog. Thanks again for your enduring patience.
Posted Oct 13, 2016 - 16:24 UTC
Investigating
We are seeing a high level of stale OS X VMs and we need to stop the workers to allow us to clean them up. Sorry for the inconvenience and we will give an update ASAP. Thank you for your patience.
Posted Oct 13, 2016 - 15:45 UTC