macOS maintenance required
Incident Report for Travis CI
Resolved
We have resolved the issue with the orphaned VMs, and macOS builds are now back to normal. We thank you for your patience during this time.
Posted Dec 02, 2017 - 02:04 UTC
Update
We are no longer seeing delays on our .com infrastructure, but some still remain on .org. We are seeing positive performance changes, however, and will continue to work towards fully resolving it.
Posted Dec 01, 2017 - 23:39 UTC
Update
The process to clean up VMs is still ongoing, but is taking longer than expected. We will provide another update as soon as we have anything new to share. We thank you for your patience during this time.
Posted Dec 01, 2017 - 22:40 UTC
Update
We are still in the process of cleaning up orphaned VMs, the process is ongoing but slow. Due to this, we expect ongoing reduced capacity. We will provide an update in the next hour or so.
Posted Dec 01, 2017 - 21:50 UTC
Investigating
We are bringing down a part of our macOS infrastructure to perform unplanned maintenance. We will be clearing out VMs that are unintentionally left running and restarting them. This will help increase performance for all users. During this time, you may notice degraded macOS performance. We will provide an update in approximately one hour on the status of this maintenance.
Posted Dec 01, 2017 - 20:40 UTC