Build delays for Linux `sudo: required` Open Source projects running at travis-ci.org
Incident Report for Travis CI
Resolved
This incident has been resolved.
Posted Sep 18, 2017 - 21:31 UTC
Monitoring
We can see that the backlog for sudo-enabled builds running on GCE has cleared. We are continuing to roll out the fix to our other infrastructures.
Posted Sep 18, 2017 - 20:56 UTC
Update
We've identified that a new backend change was having a unexpected negative impact on communications with a message queue and was leading to an increased backlog. We've test out a configuration change to disable this new change and it's having the positive impact we expected, so we're continue to roll it out to all parts of our infrastructure. We'll provide updates as this rollout progress.
Posted Sep 18, 2017 - 20:03 UTC
Investigating
We’re investigating an anomaly in demand that is causing backlog on public Linux `sudo: required` builds running at travis-ci.org
Posted Sep 18, 2017 - 17:17 UTC