We've gone from approximately 2800 to 1400 builds in the public build backlog, so we're expecting things to clear up by the morning. If things do not and we need to take further action, we will open a new incident.
Posted Sep 07, 2017 - 03:01 UTC
Monitoring
We've nearly caught up with the backlog for private builds. The backlog for public builds will likely clear over night and so we'll continue to monitor things into tomorrow and re-evaluate if we feel we need to cancel any builds tomorrow. Thank you for your patience again.
Posted Sep 06, 2017 - 22:59 UTC
Update
We're still recovering things. We're catching up on the private repository backlog but still have a very large public repository backlog. We'll provide more updates as things develop. Thank you for your patience.
Posted Sep 06, 2017 - 22:01 UTC
Update
We've been able to stabilize things enough that we're bringing on some more capacity. We're still working on stabilizing everything and will provide updates as things developer. Thank you for your patience.
Posted Sep 06, 2017 - 19:36 UTC
Update
The previous message about Xcode images being unavailable was incorrect and has been removed.
Posted Sep 06, 2017 - 17:45 UTC
Identified
The host that owns several of our Xcode images has gone offline. We will be shutting down 50% of our capacity to perform emergency maintenance. Expecting longer wait times for OSX/MacOS builds. Sorry for the inconvenience.
Posted Sep 06, 2017 - 17:44 UTC
Update
We continue to work towards to clearing the macOS backlog and stabilising our network.
Posted Sep 06, 2017 - 15:15 UTC
Update
In addition to longer boot times, users are experiencing an increase in errored builds due to log timeouts when running macOS builds. We are investigating networking issues and will update again as soon as we know more.
Posted Sep 06, 2017 - 10:45 UTC
Investigating
We’re investigating an increased rate of internal restarts of macOS builds, resulting in longer boot times for both public and private repositories. This has resulted in an increased backlog for macOS builds at travis-ci.org