Python packages installation failure for sudo-enabled builds
Incident Report for Travis CI
Resolved
The network reachability issues affecting connections from our `sudo: required` infrastructure to hosts like files.pythonhosted.org, Hashicorp or Sauce Connect seem to have been resolved. The problem was due to a connectivity issue between our infrastructure provider and an upstream CDN. We recommend restarting any affected builds, which should no longer present these errors. If you're still experiencing this problem, please let us know at support@travis-ci.com. Thank you for your understanding and patience.
Posted 5 months ago. May 07, 2018 - 17:27 UTC
Update
The Python Infrastructure team has also opened a related incident to this one at https://status.python.org/incidents/zjxwp5lpyn8s, where they are investigating access issues to files.pythonhosted.org from some providers. We’ll continue posting updates as soon as we have more information. Thank you for your patience.
Posted 5 months ago. May 07, 2018 - 16:26 UTC
Investigating
Python packages installed via `pip install` are currently failing on our sudo-enabled infrastructure i.e. builds with `sudo: required` in their .travis.yml file.

If you don't need features specific to this infrastructure (e.g. if you don't need Docker), you can try running your builds on our container-based infrastructure with `sudo: false` which is not affected by this issue.

We are looking into it.
Posted 5 months ago. May 07, 2018 - 15:51 UTC